Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

2018 Calendar Contest Winners - posted on 10th Jan 2018 at 5:38 PM
Replies: 8 (Who?), Viewed: 121 times.
Test Subject
Original Poster
#1 Old 11th Jan 2018 at 9:22 AM

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons
Default How to Turn on Smooth Edges on Super Collection
I tried the whole graphicscard fix thing but I'm pretty sure it only works on Windows because TS2 still comes out low quality and smooth edges and shadows are greyed out. I have Super Collection and I'm not using Parallels or anything like that. Any tips?
Advertisement
Lab Assistant
#2 Old 11th Jan 2018 at 9:36 AM
Are you trying to change settings from neighbourhood or lot view? Shadows will be greyed out in neighbourhood view, but can be changed when a lot is loaded. Both shadows and smooth edges work in my Super Collection game, and there is no need to touch Graphic Rules.sgr or Video Cards.sgr at all. The Super Collection is only about 3 years old, so it was already written with modern larger widescreen sizes in mind, and current(ish) Mac hardware.

Generally you shouldn't need to tweak things unless you want to install something like Voeille's Pond and Sea mod - and the only essential change for that is to add "boolProp causticsEnabled true", which you can put in your userStartup.cheat file instead.

If you do want to make further adjustments to the graphics settings though... what Mac are you using, and does it have a discrete graphics card or just an Intel integrated one (part of the CPU)? If you check the Logs directory, you'll find a file called <yourcomputername>-config-log.txt, and that should tell you what graphics card the game is using if you have more than one.

The Mac version of the game has the usual Windows versions of Graphics Rules.sgr and Video Cards.sgr under every expansion pack, and also a separate set in Contents/Resources/Config. The ones in that location appear to be what that the game actually uses, so those are the files that you need to apply the graphics fixes to.
Test Subject
Original Poster
#3 Old 11th Jan 2018 at 11:49 AM
Quote:
Originally Posted by muridae
Are you trying to change settings from neighbourhood or lot view? Shadows will be greyed out in neighbourhood view, but can be changed when a lot is loaded. Both shadows and smooth edges work in my Super Collection game, and there is no need to touch Graphic Rules.sgr or Video Cards.sgr at all. The Super Collection is only about 3 years old, so it was already written with modern larger widescreen sizes in mind, and current(ish) Mac hardware.

Generally you shouldn't need to tweak things unless you want to install something like Voeille's Pond and Sea mod - and the only essential change for that is to add "boolProp causticsEnabled true", which you can put in your userStartup.cheat file instead.

If you do want to make further adjustments to the graphics settings though... what Mac are you using, and does it have a discrete graphics card or just an Intel integrated one (part of the CPU)? If you check the Logs directory, you'll find a file called <yourcomputername>-config-log.txt, and that should tell you what graphics card the game is using if you have more than one.

The Mac version of the game has the usual Windows versions of Graphics Rules.sgr and Video Cards.sgr under every expansion pack, and also a separate set in Contents/Resources/Config. The ones in that location appear to be what that the game actually uses, so those are the files that you need to apply the graphics fixes to.


No matter what I do, it stays greyed. :T
Lab Assistant
#4 Old 11th Jan 2018 at 12:44 PM
So if you've tried to turn on shadows from within a lot, and that doesn't work, we'll need more information about the Mac you're running the game on, to see what it should be capable of.

What graphics card does the log file I mentioned above say that it's using?

What's the spec of your Mac? Go to the Apple menu, then About This Mac, and get the details listed for the OS version, the description of the Mac model, plus the lines for Processor and Graphics.
Test Subject
Original Poster
#5 Old 11th Jan 2018 at 9:21 PM
Quote:
Originally Posted by muridae
So if you've tried to turn on shadows from within a lot, and that doesn't work, we'll need more information about the Mac you're running the game on, to see what it should be capable of.

What graphics card does the log file I mentioned above say that it's using?

What's the spec of your Mac? Go to the Apple menu, then About This Mac, and get the details listed for the OS version, the description of the Mac model, plus the lines for Processor and Graphics.


No I meant the smooth edges is still greyed out. Shadows work fine. It's smooth edges.

MacBook Pro (13-inch, Mid 2012)
Processor 2.5 GHz Intel Core i5
Memory 4 GB 1600 MHz DDR3
Startup Disk Macintosh HD
Graphics Intel HD Graphics 4000 1536 MB
Lab Assistant
#6 Old 12th Jan 2018 at 12:39 AM
That Macbook is at the lower end of the machines that can actually play the game (very lowest is the Intel HD 3000 integrated graphics. I don't know why the smooth edges slider doesn't work for you (it does for me on my nearest equivalent, an Intel HD 5000 MacBook Air), but to be honest I wouldn't attempt to use smooth edges on a graphics card that weak anyway. It'll rev the fans like crazy - my Air did when I turned on smooth edges just to test it - and your CPU/GPU temperatures will be very high. That's not good for the CPU in the long term, so you may just have to compromise on graphics settings while this is the machine you're playing on. I think you have better fans than I do in the Air, so at least there's that.

Are you still using your adjusted Graphic Rules.sgr (and where did you put it if you are)? It might be worth reverting to the standard Graphic Rules.sgr and Video Cards.sgr files supplied by Aspyr and seeing if they help. Though they may just determine that your MacBook isn't powerful enough to cope, of course.

Take a look at your config-log.txt file. It'll show the settings your game used the last time it ran. Scroll down to the "Device properties" section at the bottom and look for "enumerateMultisampleLevels". If that's set to true, you can use smooth edges. If it's set to false your game is in too low a resolution mode to allow them.
Test Subject
Original Poster
#7 Old 12th Jan 2018 at 12:51 AM
Quote:
Originally Posted by muridae
That Macbook is at the lower end of the machines that can actually play the game (very lowest is the Intel HD 3000 integrated graphics. I don't know why the smooth edges slider doesn't work for you (it does for me on my nearest equivalent, an Intel HD 5000 MacBook Air), but to be honest I wouldn't attempt to use smooth edges on a graphics card that weak anyway. It'll rev the fans like crazy - my Air did when I turned on smooth edges just to test it - and your CPU/GPU temperatures will be very high. That's not good for the CPU in the long term, so you may just have to compromise on graphics settings while this is the machine you're playing on. I think you have better fans than I do in the Air, so at least there's that.

Are you still using your adjusted Graphic Rules.sgr (and where did you put it if you are)? It might be worth reverting to the standard Graphic Rules.sgr and Video Cards.sgr files supplied by Aspyr and seeing if they help. Though they may just determine that your MacBook isn't powerful enough to cope, of course.

Take a look at your config-log.txt file. It'll show the settings your game used the last time it ran. Scroll down to the "Device properties" section at the bottom and look for "enumerateMultisampleLevels". If that's set to true, you can use smooth edges. If it's set to false your game is in too low a resolution mode to allow them.


I was playing around with the graphic rules file and now my game crashes. I fucked something up.
Needs Coffee
staff: moderator
#8 Old 12th Jan 2018 at 1:01 AM
I think it's greyed out because your MacBook is not strong enough. Pushing a computer into higher settings can shorten the life of it, even to the point of chips melting. I would be turning shadows off to give it some more 'juice' and also keep things such as distance down to low.

"I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives." - Unknown
~Call me Jo~
Inventor
#9 Old 14th Jan 2018 at 3:33 AM
Quote:
Originally Posted by Shana4eva1
I was playing around with the graphic rules file and now my game crashes. I fucked something up.


Replace your modified graphic rules file with the original or just reinstall. Reinstalling is quite easy just move The Sims™ 2: Super Collection.app to the Trash and then empty the Trash and next re-download The Sims™ 2: Super Collection from the Mac App Store.

I don't think that if you play the game on your Macbook that you are going to get smooth edges as it is just not powerful enough. Set the settings kind of low so that the game is less graphics intensive and hope that you can have shadows.

for info on changing the Mac Open File Limit check out my post here http://www.insimenator.org/index.ph...html#msg1628939
Curiosity killed the cat,
but satisfaction brought it back.
Back to top